Service Is Down

Incident Report for Trullion

Resolved

Issue Resolved
Posted Oct 31, 2021 - 10:23 UTC

Identified

We are currently experiencing downtime.
Our engineers are investigating the issue and we'll update on the progress
Posted Oct 31, 2021 - 10:04 UTC
This incident affected: Trullion Health Check (app.trullion.com).